Switch to full style
SBR's, AOW's, Suppressors, MG's etc.

Forum rules

Discussion or advice on how to create an Illegal NFA item will result in an immediate ban. No advice given within should replace user due diligence. Always consult a lawyer / professional.
Post a reply

This doesn’t look right...

Fri Jun 07, 2019 3:05 pm

Went to SSNW today to break in my new AR pistol. Put 60 rounds downrange, about 55 of them suppressed.

I’m using a YHM QD Phantom 30 caliber can on a QD 5.56 brake. Definitely got very hot, it was smoking at times. After I took the can off, the parkerizing was completely gone. Pretty sure this is not supposed to happen.

Anyone have a clue to this? I’m definitely going to contact YHM and ask what gives as well.
You do not have the required permissions to view the files attached to this post.

Re: This doesn’t look right...

Fri Jun 07, 2019 5:01 pm

Are you sure it's gone? Did you try to clean it?

Re: This doesn’t look right...

Fri Jun 07, 2019 5:15 pm

Wow, that does look baked. The only can I ever used was directly threaded onto the barrel, after flash suppressor was removed, so not an issue in that case.

Re: This doesn’t look right...

Fri Jun 07, 2019 5:16 pm

My shit was that color this morning.

Re: This doesn’t look right...

Fri Jun 07, 2019 5:37 pm

Since we don’t know each other I’d like to preface this question because I’m not attempting to call you out.

How do you know the parkerizing is gone?
I’m looking at the images and thinking it’s “crud” that needs to be cleaned and possibly needs some scrubbing with a light oil and 0000 steel wool or a stiff nylon brush.

Re: This doesn’t look right...

Fri Jun 07, 2019 6:46 pm

Looks very similar to my 9mm Fortis brake after running it hard with the blast shield over it. It needs a bath, a good scrubbing and some oil. Mine cleaned up pretty well after a long soak in Kroil, and a few trips through the ultra sonic. I did that once. I just inspect it when I clean the rifle and keep shooting it like that. No rust forming, no other issues.

Re: This doesn’t look right...

Fri Jun 07, 2019 7:51 pm

Just put the suppressor back on and don't worry about it. :bigsmile:

Re: This doesn’t look right...

Fri Jun 07, 2019 8:14 pm

MadPick wrote:Just put the suppressor back on and don't worry about it. :bigsmile:

^This.

Re: This doesn’t look right...

Fri Jun 07, 2019 8:55 pm

Trogdor wrote: Definitely got very hot, it was smoking at times.


You pretty much answered your own question right there. If you're willing to shoot your guns to the point they are smoking hot, don't be surprised when things change colors and some coatings get damaged.

The pic looks like you burned/baked the oil trapped in the parkerizing.

Re: This doesn’t look right...

Fri Jun 07, 2019 11:02 pm

Welcome to the suppressed life. I'd expect any finish on a muzzle device to go to shit very quickly. Atleast everyone knows you arnt a poser.

Re: This doesn’t look right...

Sat Jun 08, 2019 7:51 pm

dreadi wrote:Since we don’t know each other I’d like to preface this question because I’m not attempting to call you out.

How do you know the parkerizing is gone?
I’m looking at the images and thinking it’s “crud” that needs to be cleaned and possibly needs some scrubbing with a light oil and 0000 steel wool or a stiff nylon brush.


I guess that’s fair. It may not be.

I run the same can on my M1A and it hasn’t done that to the flash hider on it, though. There is certainly a lot of crud inside the can, so maybe that is the case.

This is my first time running a can on an AR, so I just wasn’t expecting it to come out that way. Especially for the first use.

Re: This doesn’t look right...

Sat Jun 08, 2019 7:53 pm

Yondering wrote:
Trogdor wrote: Definitely got very hot, it was smoking at times.


You pretty much answered your own question right there. If you're willing to shoot your guns to the point they are smoking hot, don't be surprised when things change colors and some coatings get damaged.

The pic looks like you burned/baked the oil trapped in the parkerizing.


The thing is, I wasn’t firing that fast. Basically a round every 5 seconds with some long breaks essentially every ten rounds. I didn’t think it would get that hot at that rate.

Re: This doesn’t look right...

Sat Jun 08, 2019 7:57 pm

Mediumrarechicken wrote:Welcome to the suppressed life. I'd expect any finish on a muzzle device to go to shit very quickly. Atleast everyone knows you arnt a poser.


Thanks?!? Haha!

It’s definitely a learning curve. Gun worked flawlessly, thankfully. It may have been exacerbated by the fact I was running some cheap .223 through it. Looks like I have some cleaning and learning to do. I just don’t want the brake to fail.

Re: This doesn’t look right...

Wed Jun 12, 2019 7:17 am

Trogdor wrote:
Mediumrarechicken wrote:Welcome to the suppressed life. I'd expect any finish on a muzzle device to go to shit very quickly. Atleast everyone knows you arnt a poser.


Thanks?!? Haha!

It’s definitely a learning curve. Gun worked flawlessly, thankfully. It may have been exacerbated by the fact I was running some cheap .223 through it. Looks like I have some cleaning and learning to do. I just don’t want the brake to fail.

It wont fail. I guess if the look gets to you I suppose you could get some berryman parts cleaner and hang your rifle and let it soak
Post a reply