Gun store Shooting Locations It is currently Wed Aug 12, 2020 11:39 am


Rules Brads Guns Rainier Arms McCallen Killer Innovations Fessleman Firearms
WGO Chat Room Rehv Arms Vantage Reloading
Gear Fortis WCA 2A Ind. Pintos WAC
Calendar




Reply to topic  [ 1 post ] 
 Question about S&W Model 60 no dash 
Author Message
Site Supporter
User avatar
Site Supporter

Location: Kent
Joined: Wed Jul 27, 2016
Posts: 598
Real Name: Pete
I got a Wilson Combat spring kit and put it in my Model 60 today.
The install went fine, and my function check went perfect. Now to put the side plate back on.

Here is where the problem is. When I go to tighten down the 3 screws, it binds the hammer. I have the gun back together, but the screws are all barley even tight. While they are all flush with the frame and the grips are on, I feel like the screws should be tighter. Any tighter than they are now the hammer binds.

Does anyone have an idea what I'm doing wrong?

I don't want to pay for someone to fix this if I don't have to, I am just stumped.

I just did the same work on a 442 last week and it was great.

Thanks!

_________________
Pete
___________________________________
NRA Member
NRA Range Safety Officer
Good guy with a gun


Wed Jul 15, 2020 8:17 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



Rent Me Pintos NRA SAF CCKRBA
Aldersons e-arms.com


Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
[ Time : 0.792s | 14 Queries | GZIP : Off ]